re = /^(?:(?!^(?:111|11)$).)++$/m
str = '0
1
00
01
10
11
000
001
010
011
100
101
110
111
0000
0001
0010
0011
0100
0101
0110
0111
1000
1001
1010'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end