using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"IP=([0-9]{1,3})\.([0-9]{1,3})\.([0-9]{1,3})\.([0-9]{1,3})";
string input = @"IP=10.220.10.233";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}