$re = '/-?(?!0+[ +])\d*\.?\d+/m';
$str = '0+.25+4.06+5.12 0+0-.033+933.00+9+48.002';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);