package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+ *[ -:] *\w+$`)
var str = `Villa-Levski
Villa:Levski
Villa Levski
Villa123-Levski123
Villa123:Levski123
Villa123 Levski123
Villa - Levski
Villa : Levski
Villa Levski`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}