import re
regex = re.compile(r"(?<= )(\S+ *)$", flags=re.MULTILINE)
test_str = "Bob Jane"
subst = ",\\1"
result = regex.sub(subst, test_str)
if result:
print(result)