$re = '/(.)(.*)({)/m';
$str = 'body {
background: red;
background-image: url(gory8.jpg) ;
}
.wrap {
background:yellow ;
margin: auto ;
width: 700px ;
height: 400px ;
z-index: 3 ;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);