# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\(?(\b(Gen(?:esis)?|Exo(?:dus)?|Lev(?:iticus)?|Num(?:bers)?|Deut(?:eronomy)?|Josh(?:ua)?|Judg(?:es)?|Ru(?:th)?|(?:1st|1|First)\ Sam(?:uel)?|(?:2nd|2|Second)\ Sam(?:uel)?|(?:1st|1|First)\ Kings|(?:2nd|2|Second)\ Kings|(?:1st|1|First)\ Chr(?:onicles|on)?|(?:2nd|2|Second)\ Chr(?:onicles|on)?|Ezr(?:a)?|Neh(?:emiah)?|Est(?:her)?|Job|Psa(?:lms?)?|Prov(?:erbs)?|Eccles(?:iastes)?|Songs|(?:Song\ of\ )?Solomon|Isa(?:iah)?|Jer(?:emiah)?|Lam(?:entations)?|Eze(?:kiel)?|Dan(?:iel)?|Hos(?:ea)?|Joel|Am(?:os)?|Obad(?:iah)?|Jon(?:ah)?|Micah|Na(?:hum)?|Hab(?:akkuk)?|Zeph(?:aniah)?|Hagg(?:ai)?|Zech(?:ariah)?|Mal(?:achi)?|Matt(?:hew)?|Mark|Luke|John|Acts|Rom(?:ans)?|(?:1st|1|First)\ Cor(?:inthians)?|(?:2nd|2|Second)\ Cor(?:inthians)?|Gal(?:atians)?|Eph(?:esians)?|Phil(?:ippians)?|Col(?:ossians)?|(?:1st|1|First)\ Thess(?:alonians)?|(?:2nd|2|Second)\ Thess(?:alonians)?|(?:1st|1|First)\ Tim(?:othy)?|(?:2nd|2|Second)\ Timothy|Tit(?:us)?|Philem(?:on)?|Heb(?:rews)?|James|(?:1st|1|First)\ Peter|(?:2nd|2|Second)\ Peter|(?:1st|1|First)\ John|(?:2nd|2|Second)\ John|(?:3rd|3|Third)\ John|Jud(?:e)?|Rev(?:elation)?)\b\s?(\b(?:[1-9]\d?|1[0-4]\d|150)\b(?!\s*-\s*\d+\b:)(?:\s*-\s*\b(?:[1-9]\d?|1[0-4]\d|150)\b)?(?!\s*:\s*,))(?:\s*:\s*(?!\s*,)((?:(?:\s*,\s*)?\b(?:[1-9]\d?|1[0-6]\d|17[0-6])\b(?:\s*-\s*\b(?:[1-9]\d?|1[0-6]\d|17[0-6])\b)?)+))?)\)?"
test_str = ("SHOULD MATCH:\n"
"# Single chapters only:\n"
" 2nd Kings 1 2 Kings 1 Second Kings 1\n"
" Genesis 1 (Genesis 1) Gen 1 (Gen 1)\n"
" matthew 4\n"
" 1 chr 1 2nd Chron 3 1st Chronicles 8\n\n"
"# Single chapter with single verse:\n"
" Gen 1:1 Genesis 1:1 (Gen 1:1)\n\n"
"# Single chapter with range of verses:\n"
" Ezra 1:1-3 Hos 150:175-176\n\n"
"# Single chapter with comma-separated verses:\n"
" Daniel 5:6,7 Daniel 1:2,3,4\n\n"
"# Range of chapters:\n"
" Genesis 1-5 Ruth 99-150\n\n\n"
"SHOULD NOT MATCH:\n"
"# Verse only\n"
" Job :3\n\n"
"# Range of chapters WITH verse:\n"
" Psalms 1-3:4\n\n"
"# Range of chapters WITH range of verses:\n"
" Proverbs 33-44:55-66\n\n"
"# Chapter with comma before verse:\n"
" Solomon 5:,4\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.