re = /^From:\s[A-Za-z]+\s[A-Za-z]+(\s[A-Za-z]+)?(\s[A-Za-z]+)?\s<[A-Za-z]+\.[A-Za-z]+@domain\.com>/m
str = 'From: FirstName Surname <FirstName.Surname@domain.com>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end