$re = '/([A-Za-z]{2}[\d]{10})/';
$str = 'Steht JD1234567890 irgendwo?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);