$re = '/([^*]+)\*(\d+)/';
$str = 'scratch_alpha1*12';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);