$re = '/(?<=ref{)[^}]*(?=})/im';
$str = '"text \\ref{?bar labels precision} and more text \\ref{?table column alignment}", "text \\ref{?table space} }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);