#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:(?:EXONERAR|d[ae]|por|símbolo)\s([^,]+?)(?: e Gestão)?,|\b(?!SEI\b)([A-Z\d]+-\s*\d+)|SEI-\s*([\d \/]+)\b|\b([A-Z]+(?:[\s-]+[A-Z]+)+(?=,)))"
Local $sString = "EXONERAR, com validade a contar de 19 de agosto de 2020, DE-" & @CRLF & _
"NILSON DE BRITO LIMA, ID FUNCIONAL Nº 2100423-4, do cargo" & @CRLF & _
"em comissão de Coordenador, símbolo DAS-8, da Coordenadoria de" & @CRLF & _
"Gestão Centralizada de Serviços, da Superintendência de Gestão" & @CRLF & _
"Centralizada, da Subsecretaria de Logística, da Secretaria de Estado" & @CRLF & _
"de Planejamento e Gestão. Processo nº SEI-120001/010643/2020" & @CRLF & _
"" & @CRLF & _
"EXONERAR, a pedido, NADIA NAKAMURA VIEIRA, ID FUNCIONAL" & @CRLF & _
"Nº 5099589-8, do cargo em comissão de Assessor Especial, símbolo" & @CRLF & _
"DG, da Secretaria de Estado de Planejamento e Gestão. Processo nº" & @CRLF & _
"SEI-150001/004627/2020" & @CRLF & _
"" & @CRLF & _
"EXONERAR, com validade a contar de 26 de novembro de 2020," & @CRLF & _
"BRUNO RAFAEL ROCHA COSTA, ID FUNCIONAL Nº 5108093-1, do" & @CRLF & _
"cargo em comissão de Assessor, símbolo DAS-7, da Assessoria de" & @CRLF & _
"Planejamento e Gestão, da Presidência, da Superintendência de Des-" & @CRLF & _
"portos do Estado do Rio de Janeiro - SUDERJ, da Secretaria de Es-" & @CRLF & _
"tado de Esporte, Lazer e Juventude. Processo nº SEI-" & @CRLF & _
"3 0 0 0 0 2 / 0 0 0 4 11 / 2 0 2 0 ." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"EXONERAR MONIQUE SANTOS NAZÁRIO, ID FUNCIONAL" & @CRLF & _
"5009814-4, com validade a contar de 26 de novembro de 2020, do" & @CRLF & _
"cargo em comissão de Diretora de Divisão de Alimentação, símbolo" & @CRLF & _
"DAS-6, da Superintendência de Contratos e Convênios da Subsecre-" & @CRLF & _
"taria de Gestão Finanças e Planejamento da Secretaria de Estado de" & @CRLF & _
"Administração Penitenciária, Processo nº SEI-210001/004035/2020." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")