import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w]+)\\s?=\\s?([-+\\s]*?([0-9]*\\.[0-9]+|[0-9]+))?([-+])*([Ss]in|[Rr]amp)\\((?:FinalValue:|Amplitude:)([-+\\s]*?([0-9]*\\.[0-9]+|[0-9]+))([\\w]*),(?:Frequency:|RampTime:)([0-9]*\\.[0-9]+|[0-9]+)([\\w]*)\\)";
final String string = "Rx_TrqMax_Rq = Ramp(FinalValue:100Nm,RampTime:10ms)\n"
+ "Rx_TrqMax_Rq =100+Ramp(FinalValue:100.50Nm,RampTime:10ms)\n"
+ "Rx_TrqMax_Rq = -100.50+Ramp(FinalValue:100Nm,RampTime:10ms)\n"
+ "Rx_TrqMax_Rq = -100.50-Ramp(FinalValue:100Nm,RampTime:10ms)\n"
+ "Rx_TrqMax_Rq = 100+Sin(Amplitude:100Nm,Frequency:10ms)\n"
+ "Rx_TrqMax_Rq = -100-Sin(Amplitude:100Nm,Frequency:10ms)\n"
+ "Rx_TrqMax_Rq = Sin(Amplitude:100Nm,Frequency:10ms)\n"
+ "Rx_TrqMax_Rq = 100+Sin(Amplitude:100Nm,Frequency:10ms)\n"
+ "Rx_TrqMax_Rq = 100.50+Sin(Amplitude:100Nm,Frequency:10.5s)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}