package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^((a|b|start)(\d+%)?(\d+(s|ms))?)+$`)
var str = `b50%25ms
a500ms50ms
a500msb50ms
start200s
start20%12ms
a600msb200ms
astart
a
b
Invalid
a500ms50%
ams500b #ms does not have duration
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}