re = /-(?![^-\n]*-)|\./m
str = 'id-string1-string2-string3.extension
Il2dK-Ud2d9-Kod2d-d9dwo.jpg
j54fwf3da-7jrg-9eujodww-kio98ujk.png
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end