// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)[^\n.!?:]*(?:thanks[ .?!]*$|thank[ -]you[ .?!]*$|(?:please|help|suggest(?:ions)|thanks)\b[^\n.!?:]*\b(?:help|ap+reciat\w*|me|advan\w*|a ?lot)\b[^\n.!?:]*)[.!?]*[ ]*").unwrap();
let string = "I don't know what's going on. Any help would be appreciated. How can I do this?
Any suggestions are appreciated :)
Please help me, i will thank you. How I do this?
I hope you guys can help me. Thanks for any help.
All suggestions are appreciated, thanks
Thanks in advance.
Could you help me?
I hope you can please help me buddy!
please help
Can someone please guide me where I am going wrong ?
I have no teacher or any instructor because I am learning programming on my own, so please any help is appreciated. Thanks
thanks in advance!
thanks in advantage!
Thanks in advance!
kindly help me with the step by step solution.. thanks in advance
__Thanks in advance.__
Thanks a lot!
Thank you!!!
also id like to thank you for any help in advance. let me first state that i am aware of possible security issues and will address those accordingly.
thanks!!
Do Not Match:
Software for tanks. It would please my boss.
Please look at this example.
Thanks to Microsoft, I can no longer log in to my email.
Please stop sending me emails Microsoft! << Nobody has ever said that on SO.
Please don't ever do this. << This is a common statement in PHP/MySQL answers!
Please don't tell me you are using regular expressions to validate urls when there's the Uri.TryCreate method.
Thank you to AndrewMalinnkov for the answer!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}