#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)[^\n.!?:]*(?:thanks[ .?!]*$|thank[ -]you[ .?!]*$|help[ .?!]*$|(?:please|help|suggest(?:ions)|thanks)\b[^\n.!?:]*\b(?:help|ap+reciat\w*|me|advan\w*|a ?lot)\b[^\n.!?:]*)[.!?_*]*[ ]*"
Local $sString = "I don't know what's going on. Any help would be appreciated. How can I do this?" & @CRLF & _
"" & @CRLF & _
"Any suggestions are appreciated :)" & @CRLF & _
"" & @CRLF & _
"Please help me, i will thank you. How I do this?" & @CRLF & _
"" & @CRLF & _
"I hope you guys can help me. Thanks for any help." & @CRLF & _
"" & @CRLF & _
"All suggestions are appreciated, thanks" & @CRLF & _
"" & @CRLF & _
"Thanks in advance." & @CRLF & _
"" & @CRLF & _
"Could you help me?" & @CRLF & _
"" & @CRLF & _
"I hope you can please help me buddy!" & @CRLF & _
"" & @CRLF & _
"please help" & @CRLF & _
"" & @CRLF & _
"Can someone please guide me where I am going wrong ?" & @CRLF & _
"" & @CRLF & _
"I have no teacher or any instructor because I am learning programming on my own, so please any help is appreciated. Thanks" & @CRLF & _
"" & @CRLF & _
"thanks in advance!" & @CRLF & _
"" & @CRLF & _
"thanks in advantage!" & @CRLF & _
"" & @CRLF & _
"Thanks in advance!" & @CRLF & _
"" & @CRLF & _
"kindly help me with the step by step solution.. thanks in advance" & @CRLF & _
"" & @CRLF & _
"__Thanks in advance.__" & @CRLF & _
"" & @CRLF & _
"Thanks a lot!" & @CRLF & _
"" & @CRLF & _
"Thank you!!!" & @CRLF & _
"" & @CRLF & _
" also id like to thank you for any help in advance. let me first state that i am aware of possible security issues and will address those accordingly." & @CRLF & _
"" & @CRLF & _
"thanks!!" & @CRLF & _
"" & @CRLF & _
"Do Not Match:" & @CRLF & _
"" & @CRLF & _
"Software for tanks. It would please my boss. " & @CRLF & _
"" & @CRLF & _
"Please look at this example." & @CRLF & _
"" & @CRLF & _
"Thanks to Microsoft, I can no longer log in to my email." & @CRLF & _
"" & @CRLF & _
"Please stop sending me emails Microsoft! << Nobody has ever said that on SO." & @CRLF & _
"" & @CRLF & _
"Please don't ever do this. << This is a common statement in PHP/MySQL answers!" & @CRLF & _
"" & @CRLF & _
"Please don't tell me you are using regular expressions to validate urls when there's the Uri.TryCreate method." & @CRLF & _
"" & @CRLF & _
"Thank you to AndrewMalinnkov for the answer!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")