$re = '/^hello\s(\w*)\s?dolly/m';
$str = 'hello there dolly
hello dolly';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);