$re = '/^((?!hello|goodby)[\s\w]+) ((?!word|cosmos)[\s\w]+)!/';
$str = 'hi mam!';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);