re = /,(?=(?:[^"]*"[^"]*")*[^"]*$)/
str = '"Field1,Field2","Field2","item1,item2,item3"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end