import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=statement: )([ _\\-|0-9,:;\\.=A-Za-z\\(\\)\"\\n\\t'].+?)(?=\\d{4}-\\d{2}-\\d{2}|$)";
final String string = "2015-05-20 02:27:41 GMT 555bbcfd.3685 cmsmgt001 LOG: statement: COMMIT\n"
+ "2015-05-20 02:27:41 GMT 555bcdb3.3908 cmsmgt001 LOG: statement: BEGIN\n"
+ "2015-05-20 02:27:41 GMT 555bcdb3.3908 cmsmgt001 LOG: statement: SET search_path TO pC35126D4,public;\n"
+ "2015-05-20 02:27:41 GMT 555bcdb3.3908 cmsmgt001 LOG: statement: SELECT cms_images.id, cms_images.url, cms_images.uploaded_filename, cms_images.size, cms_images.width, cms_images.height, cms_images.ext, cms_images.data, cms_images.hash_sha1, cms_images._created, cms_images._modified, cms_images._hash \n"
+ "FROM cms_images \n"
+ "WHERE cms_images.id = 912148443466212857204723 \n"
+ "LIMIT 1\n"
+ "2015-05-20 02:27:41 GMT 555bcdb3.3908 cmsmgt001 LOG: statement: ROLLBACK\n"
+ "2015-05-20 02:27:41 GMT 555bbb9f.364b cmsmgt001 LOG: statement: BEGIN\n"
+ "2015-05-20 02:27:41 GMT 555bbb9f.364b cmsmgt001 LOG: statement: SET search_path TO pC35126D4,public;\n"
+ "2015-05-20 02:27:41 GMT 555bbb9f.364b cmsmgt001 LOG: statement: SELECT cms_images.id, cms_images.url, cms_images.uploaded_filename, cms_images.size, cms_images.width, cms_images.height, cms_images.ext, cms_images.data, cms_images.hash_sha1, cms_images._created, cms_images._modified, cms_images._hash \n"
+ "FROM cms_images \n"
+ "WHERE cms_images.hash_sha1 = '035f3fac7dd057bac10f2203ecb8ea6a97d2116c' \n"
+ "LIMIT 1\n"
+ "2015-05-20 02:27:41 GMT 555bbb9f.364b cmsmgt001 LOG: statement: ROLLBACK\n"
+ "2015-05-20 02:27:41 GMT 555bc0dd.372c cmsmgt001 LOG: statement: BEGIN\n"
+ "2015-05-20 02:27:41 GMT 555bc0dd.372c cmsmgt001 LOG: statement: SET search_path TO pC35126D4,public;\n"
+ "2015-05-20 02:27:41 GMT 555bc0dd.372c cmsmgt001 LOG: statement: SELECT cms_images.id, cms_images.url, cms_images.uploaded_filename, cms_images.size, cms_images.width, cms_images.height, cms_images.ext, cms_images.data, cms_images.hash_sha1, cms_images._created, cms_images._modified, cms_images._hash \n"
+ "FROM cms_images \n"
+ "WHERE cms_images.hash_sha1 = '035f3fac7dd057bac10f2203ecb8ea6a97d2116c' \n"
+ "LIMIT 1\n"
+ "2015-05-20 02:27:41 GMT 555bc0dd.372c cmsmgt001 LOG: statement: ROLLBACK\n"
+ "2015-05-20 02:27:41 GMT 555bbc90.3665 cmsmgt001 LOG: statement: BEGIN\n"
+ "2015-05-20 02:27:41 GMT 555bbc90.3665 cmsmgt001 LOG: statement: SET search_path TO pC35126D4,public;\n"
+ "2015-05-20 02:27:41 GMT 555bbc90.3665 cmsmgt001 LOG: statement: SELECT cms_celebrities.id, cms_celebrities.vendor, cms_celebrities.tms_person_id, cms_celebrities.birth_year, cms_celebrities.first_name, cms_celebrities.last_name, cms_celebrities.display_name, cms_celebrities.image_id, cms_celebrities._created, cms_celebrities._modified, cms_celebrities._hash \n"
+ "FROM cms_celebrities \n"
+ "WHERE cms_celebrities.tms_person_id = '47088' \n"
+ "LIMIT 1\n"
+ "2015-05-20 02:27:41 GMT 555bbc90.3665 cmsmgt001 LOG: statement: ROLLBACK\n"
+ "2015-05-20 02:27:41 GMT 555bbcc8.3670 cmsmgt001 LOG: statement: BEGIN\n"
+ "2015-05-20 02:27:41 GMT 555bbcc8.3670 cmsmgt001 LOG: statement: SET search_path TO pC35126D4,public;\n"
+ "2015-05-20 02:27:41 GMT 555bbcc8.3670 cmsmgt001 LOG: statement: select nextval('\"cms_celebrities_id_seq\"')\n"
+ "2015-05-20 02:27:41 GMT 555bbcc8.3670 cmsmgt001 LOG: statement: INSERT INTO cms_celebrities (id, vendor, tms_person_id, birth_year, first_name, last_name, display_name, image_id, _created, _modified, _hash) VALUES (1571, 'gracenote', '47088', 1925, 'Monique', 'Van Vooren', 'Monique Van Vooren', 1701, '2015-05-20T02:27:41.768803'::timestamp, '2015-05-20T02:27:41.768803'::timestamp, '2015-05-20 02:27:41.768803|7111|0.7293680991519143')\n"
+ "2015-05-20 02:27:41 GMT 555bbcc8.3670 cmsmgt001 LOG: statement: COMMIT\n"
+ "2015-05-20 02:27:41 GMT 555bbd8b.3698 cmsmgt001 LOG: statement: BEGIN\n"
+ "2015-05-20 02:27:41 GMT 555bbd8b.3698 cmsmgt001 LOG: statement: SET search_path TO pC35126D4,public;\n"
+ "2015-05-20 02:27:41 GMT 555bbd8b.3698 cmsmgt001 LOG: statement: SELECT cms_asset_celebrities.id, cms_asset_celebrities.asset_id, cms_asset_celebrities.celebrity_id, cms_asset_celebrities.role, cms_asset_celebrities.order_pos, cms_asset_celebrities._created, cms_asset_celebrities._modified, cms_asset_celebrities._hash \n"
+ "FROM cms_asset_celebrities \n"
+ "WHERE celebrity_id=1571 \n"
+ "LIMIT 1";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}