package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^.?|\.[^d]|[^.]d|[^.][^d])\.ts$`)
var str = `some-string.ts
some-string.d.ts
some-stringd.ts
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}