#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[PC]\(\d+[ ,]\s*\d+\)"
Local $sString = "C(1, 2)" & @CRLF & _
"P(2 3)" & @CRLF & _
"C(43)" & @CRLF & _
"C(43, )" & @CRLF & _
"P(43,2)" & @CRLF & _
"C(444 123)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")