re = /^(-?<\d+\.\d+>)|(<-?\d+\.\d+>)|(-?\d+\.\d+)$/m
str = '-11.88
<0.012541>
-<3.14>
<-2.98>
<1.23
<-abcdefg>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end