$re = '/(?:http:\/|https:\/)(*SKIP)(*F)|:\//';
$str = ':/ ewqeqw eqweqwe qwe http:// ewr ewr erwer ewr:) :/ dasd ewwqeqwe https:// ddfds :/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);