#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[[Video:(http)\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,3}(\/\S*)?4"
Local $sString = " <p class="arttxt_tit">ARTBLOG YAZARIMIZ OLUN! ekavArtblog</p>" & @CRLF & _
" <p class="arttxt"><i>22.11.2011</i></p>" & @CRLF & _
" <p class="arttxt">" & @CRLF & _
" <p style="text-align: center;">" & @CRLF & _
" <br />" & @CRLF & _
" <img alt="" src="http://www.ekavart.tv/handlers/Image.ashx?id=984" style="width: 364px; height: 272px;" /><br />" & @CRLF & _
" <br />" & @CRLF & _
" <br />" & @CRLF & _
" Sanatla ilgili her türlü yazınısı bizle paylaşın, yayınlayalım.<br />" & @CRLF & _
" <br />" & @CRLF & _
" Yazılarınızı, iletişim bilgilerinizle beraber info@ekavart.tv adresine en az 5 görselle gönderebilirsiniz.</p>" & @CRLF & _
"[[Video:http://data.ekavart.tv/ekav/temp/mp4/2016/7/13/3061.mp4" & @CRLF & _
" </p>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")