const regex = /(?<sub_all>
(?:
(?<!\\)\~
(?<sub_text>
(?>\\[\~[:blank:]\h]|[^\~[:blank:]\h\v])*+
)
(?<!\\)\~
)
|
(?: # or the Microsoft way. Beurk
\<sub\>
(?<sub_text>
((?!\v).)+
)
\<\/sub\>
)
)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<sub_all>
(?:
(?<!\\\\)\\~
(?<sub_text>
(?>\\\\[\\~[:blank:]\\h]|[^\\~[:blank:]\\h\\v])*+
)
(?<!\\\\)\\~
)
|
(?: # or the Microsoft way. Beurk
\\<sub\\>
(?<sub_text>
((?!\\v).)+
)
\\<\\\/sub\\>
)
)', 'g')
const str = `log~10~100 is 2.
Space is not allowed:
P~a cat~
But it's ok if it is escaped
P~a\\ cat~
Line break is a no-no, even escaped
P~a\\
cat~
Hmm <sub>This is a Microsoft subscript!</sub>
H~2~0
text~a\\ superscript~
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}