const regex = /([<>]=?)|=/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([<>]=?)|=', 'g')
const str = `4>3
3<5
4<=4
5>=5
4=4
5>>3
3<<5
5==5
10>5=>5>2.5=<20>10
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}