$re = '/\+359[ ]\d[ ]\d{3}[ ]\d{4}\b|(\B\+359[-]\d[-]\d{3}[-]\d{4}\b)/';
$str = 'Ivan Ivanov
ivan ivanov, Ivan ivanov, ivan Ivanov, IVan Ivanov, Ivan IvAnov,
Ivan Ivanov
+359 2 222 2222
+359-2-222-2222
359-2-222-2222, +359/2/222/2222, +359-2 222 2222, d+359 2 222 2222
+359 2-222-2222, +359-2-222-222, +359-2-222-22222, =+359-2-222-2222, +359 2 987 0123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);