$re = '/(\(\d{2}\) \d{4,5}-\d{4})/';
$str = '(99) 9999-9999
(99) 99999-9999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);