re = /\/(Sites)*\/.*\/Sites\/(.+?)\/(.+?)\/.*/i
str = '/Users/demo/Sites/Work/GitHub/ADThemes/Sites/test.com/dev/webroot/css/file.css
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end