# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?'MAJOR'0|(?:[1-9]\d*))\.(?'MINOR'0|(?:[1-9]\d*))\.(?'PATCH'0|(?:[1-9]\d*))(?:-(?'prerelease'(?:0|(?:[1-9A-Za-z-][0-9A-Za-z-]*))(?:\.(?:0|(?:[1-9A-Za-z-][0-9A-Za-z-]*)))*))?(?:\+(?'build'(?:0|(?:[1-9A-Za-z-][0-9A-Za-z-]*))(?:\.(?:0|(?:[1-9A-Za-z-][0-9A-Za-z-]*)))*))?$"
test_str = ("1.0.0-alpha-a.b-c-somethinglong+build.1-aef.1-its-okay\n"
"1.0.0+0.build.1-rc.10000aaa-kk-0.1\n"
"1.0.0-rc.1+build.1\n"
"2.0.0-rc.1+build.123\n"
"0.0.4\n"
"1.2.3\n"
"10.20.30\n"
"1.2.3-beta\n"
"10.2.3-DEV-SNAPSHOT\n"
"1.2.3-SNAPSHOT-123\n"
"1.0.0\n"
"2.0.0\n"
"1.1.7\n"
"2.0.0+build.1848\n"
"2.0.1-alpha.1227\n"
"1.2.3----RC-SNAPSHOT.12.9.1--.12+788\n\n\n"
"01.1.1\n"
"1.2\n"
"1.2.3.DEV\n"
"1.2-SNAPSHOT\n"
"1.2.3----RC-SNAPSHOT.12.09.1--..12+788\n"
"1.2-RC-SNAPSHOT\n"
"-1.0.3-gamma+b7718\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.