re = /^(?<FOOTER_TYPE>[ a-zA-Z0-9-]+)?(?<SEPARATOR>:)?(?<FOOTER>(?<=:)(.|[\r\n](?![\r\n]))*)?/
str = 'BREAKING CHANGE:test
my multiline
string.
This is not matched
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end