import re
regex = re.compile(r"^chr(1?[0-9]|2[0-2]|X|Y)", flags=re.MULTILINE)
test_str = ("chr1 3009844 3009908 DXX 42 -\n"
"chr2 3000386 3000450 DXX 15 -\n"
"chr3 3000386 3000450 DXX 15 -\n"
"chr4 3000386 3000450 DXX 15 -\n"
"chr5 3000386 3000450 DXX 15 -\n"
"chr6 3000386 3000450 DXX 15 -\n"
"chr7 3000386 3000450 DXX 15 -\n"
"chr8 3000386 3000450 DXX 15 -\n"
"chr9 3000386 3000450 DXX 15 -\n"
"chr10 3000386 3000450 DXX 15 -\n"
"chr11 3000386 3000450 DXX 15 -\n"
"chr12 3000386 3000450 DXX 15 -\n"
"chr13 3000386 3000450 DXX 15 -\n"
"chr14 3000386 3000450 DXX 15 -\n"
"chr15 3000386 3000450 DXX 15 -\n"
"chr16 3000386 3000450 DXX 15 -\n"
"chr17 3000386 3000450 DXX 15 -\n"
"chr18 3000386 3000450 DXX 15 -\n"
"chr19 3000386 3000450 DXX 15 -\n"
"chrX 3000386 3000450 DXX 15 -\n"
"chrY 3000386 3000450 DXX 15 -\n"
"chr1_GL456210_random 3000386 3000450 DXX 15 -\n"
"chr1_GL456211_random 3000386 3000450 DXX 15 -\n"
"chr1_GL456212_random 3000386 3000450 DXX 15 -\n"
"chr1_GL456221_random 3000386 3000450 DXX 15 -\n"
"chr4_GL456216_random 3000386 3000450 DXX 15 -\n"
"chr4_JH584292_random 3000386 3000450 DXX 15 -\n"
"chr4_JH584295_random 3000386 3000450 DXX 15 -\n"
"chr5_GL456354_random 3000386 3000450 DXX 15 -\n"
"chr5_JH584296_random 3000386 3000450 DXX 15 -\n"
"chr5_JH584297_random 3000386 3000450 DXX 15 -\n"
"chr5_JH584299_random 3000386 3000450 DXX 15 -\n"
"chrX_GL456233_random 3000386 3000450 DXX 15 -")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")