#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d{1,2}[\/-]\d{1,2}[\/-]\d{4}"
Local $sString = "ASTA n° 30 | 13/12/2015 ore 10.00 | Arte Moderna & Contemporanea" & @CRLF & _
"ASTA n° 30 | 1/12/2015 ore 10.00 | Arte Moderna & Contemporanea" & @CRLF & _
"ASTA n° 30 | 13/1/2015 ore 10.00 | Arte Moderna & Contemporanea" & @CRLF & _
"ASTA n° 30 | 13-12-2015 ore 10.00 | Arte Moderna & Contemporanea" & @CRLF & _
"ASTA n° 30 | 13/12-2015 ore 10.00 | Arte Moderna & Contemporanea" & @CRLF & _
"ASTA n° 30 | 13/12/2015 ore 10.00 | Arte Moderna & Contemporanea"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")