package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{1,2}[\/-]\d{1,2}[\/-](?:\d{4}|\d{2}))`)
var str = `ASTA n° 30 | 13/12/2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 1/12/2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 13/1/2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 13-12-2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 13/12-2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 13/12/15 ore 10.00 | Arte Moderna & Contemporanea`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}