package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<\s*meta\s
# using lookahead to capture type to $1
(?=[^>]*?
\b(?:name|property|http-equiv)\s*=\s*
(?|"\s*([^"]*?)\s*"|'\s*([^']*?)\s*'|
([^"'>]*?)(?=\s*/?\s*>|\s\w+\s*=))
)
# capture the content to $2
[^>]*?\bcontent\s*=\s*
(?|"\s*([^"]*?)\s*"|'\s*([^']*?)\s*'|
([^"'>]*?)(?=\s*/?\s*>|\s\w+\s*=))
[^>]*>
`)
var str = `<meta content = foo name = bar />
<meta name= bar sdf content= foo >
<meta content="name" name="author">
<meta name ="keywords" content = " php documentation ">
<meta name= "DESCRIPTION" content=" a php manual ">
<meta name="geo.position" content="49.33;-86.59 ">
<meta content=' 49.33;-86.59' name = geo.position >`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}