#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(?<=CN\=).*?(?=,)"
Local $sString = "Computer Location = afp.local/EANG" & @CRLF & _
"Description = RED_TXT" & @CRLF & _
"Device Name = EANG04W" & @CRLF & _
"Domain Name = afp.local" & @CRLF & _
"Full Name = Admintech" & @CRLF & _
"Hardware Monitoring Type = ASIC2" & @CRLF & _
"Last Blocked Application Scan Date = 1420558125" & @CRLF & _
"Last Custom Definition Scan Date = 1348087114" & @CRLF & _
"Last Hardware Scan Date = 1420533869" & @CRLF & _
"Last Policy Sync Date = 1420533623" & @CRLF & _
"Last Software Scan Date = 1420533924" & @CRLF & _
"Last Update Scan Date = 1420558125" & @CRLF & _
"Last Vulnerability Scan Date = 1420558125" & @CRLF & _
"LDAP Location = **CN=EANG04W**,OU=EANG,DC=afp,DC=local" & @CRLF & _
"Login Name = ADMINTECH" & @CRLF & _
"Main Board OEM Name = Dell Inc." & @CRLF & _
"Number of Files = 384091" & @CRLF & _
"Primary Owner = **CN= LOUHICHI anoir**,OU=EANG,DC=afp,DC=localenter code here"
Local $sSubst = "Company"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)