import re
regex = re.compile(r"(?:\bmembers\s*\{|(?<!^)\G)\s*?\n\s*(?:(?:[^{]*\{[^}]*?session-status user-disabled[^}]*\})|([^:{}]+)(?=:\d)[^{]*\{[^}]*\})", flags=re.DOTALL)
test_str = ("ltm pool TEST_POOL { \n"
" Some strings\n"
" above headers\n"
" records { \n"
" baz:1 {\n"
" ANY STRING\n"
" HERE\n"
" session-status enabled\n"
" } \n"
" foobar:23 { \n"
" ALSO ANY\n"
" STRING HERE\n"
" session-status enabled\n"
" }\n"
" }\n"
" members {\n"
" qux:45 {\n"
" ALSO ANY\n"
" STRINGS HERE\n"
" session-status enabled\n"
" }\n"
" bash:2 {\n"
" AND ANY\n"
" STRING HERE\n"
" session-status user-disabled\n"
" }\n"
" topaz:789 {\n"
" AND ANY\n"
" STRING HERE\n"
" session-status enabled\n"
" } \n"
" }\n"
" Some strings\n"
" below headers\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")