import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\p{L}{3}),\\ (\\p{L}{3})\\ (\\d\\d),\\s(\\d\\d\\d\\d)\\ at\\ (\\d\\d?):(\\d\\d)\\ ([AP]M)";
final String string = "kardashian, kim this is dummy text area\n"
+ "mercury, freddie Tue, Aug 23, 2016 at 2:21 PM\n"
+ "22.11.2016 08:58 AM\n"
+ "last_name, first_name\n"
+ "bjorge, philip ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}