# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(((0|[1-9]\d*)\.)(((0|[1-9]\d*|x)\.)?x)|main|next(-major)?|beta|alpha)$"
test_str = ("Inspired by Semantic Release Distributions Channels from Branches: https://semantic-release.gitbook.io/semantic-release/usage/configuration#branches\n\n"
"Valid Semantic Release Distribution Channels:\n\n"
"0.0.x\n"
"0.x.x\n"
"0.x\n"
"1.2.x\n"
"1.x.x\n"
"1.x\n"
"10.20.x\n"
"10.x.x\n"
"10.x\n"
"1.0.x\n"
"2.0.x\n"
"2.x.x\n"
"2.x\n"
"1.1.x\n"
"99999999999999999999999.999999999999999999.x\n"
"99999999999999999999999.x.x\n"
"99999999999999999999999.x\n"
"main\n"
"next\n"
"next-major\n"
"beta\n"
"alpha\n\n"
"Inalid Semantic Release Distribution Channels:\n\n"
"x\n"
"0.\n"
"0.xx\n"
"00.0.x\n"
"1.2\n"
"01.x\n"
"1.02.x\n"
"1.x.0\n"
"x.20.x\n"
"x.x.x\n"
"x.0.x\n"
"2.0.x-alpha\n"
"2.0.x+meta\n"
"x.x\n"
"01.1.x\n"
"99999999999999999999999.0999999999999999999.x\n"
"099999999999999999999999.x.x\n"
"mains\n"
"pre-next\n"
"next-minor\n"
"beta+\n"
"-alpha\n"
"gamma\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.