$re = '/(Select Sizes)?\s*(\w+)\s*/m';
$str = 'Select SizesS M L XL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);