using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.+screenconnect\.techmedia\.com\.au.+$";
string input = @"2020-06-12T04:04:55+10:00 mgmt-austaiaecho005.casino.internal accesslogs_splunk: Info: 1591898695.320 0 10.10.216.100 TCP_DENIED/407 0 CONNECT tunnel://screenconnect.techmedia.com.au:8080/ - NONE/- - OTHER-NONE-DefaultGroup-NONE-NONE-NONE-NONE <-,-,-,""-"",-,-,-,-,""-"",-,-,-,""-"",-,-,""-"",""-"",-,-,-,-,""-"",""-"",""-"",""-"",""-"",""-"",0.00,0,-,""-"",""-"",-,""-"",-,-,""-"",""-"",-,-,""-""> - - ""12/Jun/2020:04:04:55 +1000"" -
2020-06-12T04:04:55+10:00 mgmt-austaiaecho005.casino.internal accesslogs_splunk: Info: 1591898695.320 0 10.10.216.100 TCP_DENIED/407 0 CONNECT tunnel://screenconnect2.techmedia.com.au:8080/ - NONE/- - OTHER-NONE-DefaultGroup-NONE-NONE-NONE-NONE <-,-,-,""-"",-,-,-,-,""-"",-,-,-,""-"",-,-,""-"",""-"",-,-,-,-,""-"",""-"",""-"",""-"",""-"",""-"",0.00,0,-,""-"",""-"",-,""-"",-,-,""-"",""-"",-,-,""-""> - - ""12/Jun/2020:04:04:55 +1000"" -
2020-06-12T04:04:55+10:00 mgmt-austaiaecho005.casino.internal accesslogs_splunk: Info: 1591898695.320 0 10.10.216.100 TCP_DENIED/407 0 CONNECT tunnel://screenconnect.techmedia.com.au:8080/ - NONE/- - OTHER-NONE-DefaultGroup-NONE-NONE-NONE-NONE <-,-,-,""-"",-,-,-,-,""-"",-,-,-,""-"",-,-,""-"",""-"",-,-,-,-,""-"",""-"",""-"",""-"",""-"",""-"",0.00,0,-,""-"",""-"",-,""-"",-,-,""-"",""-"",-,-,""-""> - - ""12/Jun/2020:04:04:55 +1000"" -
2020-06-12T04:04:55+10:00 mgmt-austaiaecho005.casino.internal accesslogs_splunk: Info: 1591898695.320 0 10.10.216.100 TCP_DENIED/407 0 CONNECT tunnel://screenconnect.techmedia10.com.au:8080/ - NONE/- - OTHER-NONE-DefaultGroup-NONE-NONE-NONE-NONE <-,-,-,""-"",-,-,-,-,""-"",-,-,-,""-"",-,-,""-"",""-"",-,-,-,-,""-"",""-"",""-"",""-"",""-"",""-"",0.00,0,-,""-"",""-"",-,""-"",-,-,""-"",""-"",-,-,""-""> - - ""12/Jun/2020:04:04:55 +1000"" -";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}