$re = '/(?:{([^{}]*)}|\b\w[\w.-]*)(@[\w.-]+\.\w+)/m';
$str = 'Emails like {annie,bonnie}@gmail.com, annie2@gmail.com, then a bonnie2@gmail.com.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);