package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<[^>]+>| `)
var str = ` <i class='k-icon k-i-tree-end-branch'></i> CD001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}