import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "((?:(?(?=Fig\\.|\\d+\\.\\d).+?(?=\\s)|[^.!?])+(?=\\.))+)";
        final String string = "Test 10. Fig. 20. The decimal 20.3 should 20 still be sentence.Ok now. ";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}