#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^((?!ABCD_|IJKL).)*$"
Local $sString = "ABCD" & @CRLF & _
"EFGH" & @CRLF & _
"IJKL" & @CRLF & _
"MNOP" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")