$re = '/^(?!(?:1|2|12|34)\b)(.*)$/m';
$str = '13 ABCD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);