$re = '/[0-9]{1,2}\s[а-яА-Я]{3,}\s[0-9]{4}/ism';
$str = '
14 Марта 2012';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);